Thursday, November 8, 2012

EIGRP configuration.

This lab combines almost all CCNP related EIGRP features, excludng redistribution to/from other dynamic routing protocols:

Below are configurations of all routers with comments. Not relevant commands are omitted.
R1:
key chain KEYS #EIGRP supports only MD5 PSK authentication.
 key 1
   key-string eigrp10
   accept-lifetime 10:00:00 Jan 1 2000 10:00:00 Jan 1 2015
   send-lifetime 10:00:00 Jan 1 2000 10:00:00 Jan 1 2015
#When a router sends messages, it picks up the key with the lowest number. When a router receives messages, it checks MD5 hash among all active keys. This is why you need a NTP-server when dealing with time-based keys. Notice that on R2 I didn't specified lifetime for keys.
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet1/0
 description To R2
 no switchport
 ip address 10.0.0.1 255.255.255.252
 ip authentication mode eigrp 10 md5
#Authentication mode.
 ip authentication key-chain eigrp 10 KEYS
#And a key chain.
!
interface FastEthernet1/2
 description To R3
 no switchport
 ip address 10.0.0.5 255.255.255.252
 ip hello-interval eigrp 10 1
#Hello-interval doesn't have to match on both neighboring routers.
 ip hold-time eigrp 10 3
#Hello-interval doesn't have to match on both neighboring routers.
 delay 9
#Delay in tens of microseconds. "show interface fa1/2" will show Delay=90.
!
interface FastEthernet1/3
 description To R4
 no switchport
 ip address 10.0.0.13 255.255.255.252
!
router eigrp 10
#The AS number must match on neighboring routers.
 timers active-time 6
#Amount of time in minutes, in which this router will wait for a Reply to its Query.
 passive-interface default
#Makes all interfaces passive.
 no passive-interface FastEthernet1/0
#Then you have to manually specify not passive interfaces.
 no passive-interface FastEthernet1/2
 no passive-interface FastEthernet1/3
 network 10.0.0.0 0.0.0.3
#Or you can use classful network.
 network 10.0.0.4 0.0.0.3
#Or even 0.0.0.0 statement.
 network 10.0.0.12 0.0.0.3
 network 172.16.1.0 0.0.0.3
#You match interfaces IP addressess, not the whole prefix for advertisement. Notice, that Loopback0 has /24 prefix (which will be announced).
 metric weights 0 0 0 1 0 0
#Metric weights have to match between two neighbors. But as long as these values are configured per routing instance, they have to match among all routers in the routing domain (or AS).
 distribute-list 1 out FastEthernet1/3
#Advertise prefixes out FE1/3 that match ACL 1.
 no auto-summary
#As long there is non-contiguous network we don't need the auto-summarization at the network boundaries.
 eigrp router-id 1.1.1.1
#Two neighbor routers can have the same ID, it won't prevent the neighborship. It only matters when redistribution is in use.
 neighbor 10.0.0.6 FastEthernet1/2
#When you specify static neighbor, EIGRP stops using multicast on this interface preventing any dynamic neighborships.
!
access-list 1 deny   20.0.0.0 0.255.255.255
access-list 1 permit any
#Implicit "deny all" will prevent router from advertising any prefixes out of specified interface (FE1/2 here).
R2:
key chain KEYS #Key chain name doesn't have to match between two neighbors.
 key 1
   key-string eigrp10
!
interface Loopback0
 ip address 172.16.2.1 255.255.255.0
!
interface Loopback1
 ip address 20.0.0.1 255.255.255.0
 delay 1
#These loopbacks are used for summarization. The summary route's metric is based on the lowest metric among summarized prefixes. You can see it on neighbor routers.
!
interface Loopback2
 ip address 20.0.1.1 255.255.255.0
!
interface Loopback3
 ip address 20.0.2.1 255.255.255.0
!
interface Loopback4
 description Default Route
 ip address 200.0.0.1 255.255.255.0
!
interface FastEthernet1/0
 description To R1
 no switchport
 ip address 10.0.0.2 255.255.255.252
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 KEYS
 ip summary-address eigrp 10 20.0.0.0 255.255.252.0 5
#Number 5 here is the AD of this summary route. You don't have to specify it, IOS does it automatically.
!
interface FastEthernet1/1
 description To R3
 no switchport
 bandwidth 90000
#In Kbps.
 ip address 10.0.0.9 255.255.255.252
 ip summary-address eigrp 10 20.0.0.0 255.255.252.0 5
!
router eigrp 10
 passive-interface FastEthernet0/0
 network 10.0.0.0 0.0.0.3
 network 10.0.0.8 0.0.0.3
 network 20.0.0.0 0.0.0.255
 network 172.16.0.0 0.0.15.255
 network 200.0.0.0
#In order to advertise default route you have to match classful network among interfaces.
 metric weights 0 0 0 1 0 0
#In this lab I specified all K-values as 0, excluding the Delay to simplify the metric calculation. The metric now equals (Cumulative Delay)*256.
 no auto-summary
 eigrp router-id 2.2.2.2
 neighbor 10.0.0.10 FastEthernet1/1
!
ip default-network 200.0.0.0
#Now this network will be marked as a Candidate default, but won't  be used as default route on this router.
R3:
interface Loopback0
 ip address 172.16.3.1 255.255.255.0
!
interface Loopback1
 ip address 197.0.0.1 255.255.255.252
!
interface Loopback2
 ip address 197.0.0.5 255.255.255.252
!
interface Loopback3
 ip address 197.0.0.9 255.255.255.252
!
interface Loopback4
 ip address 197.0.0.13 255.255.255.252
!
interface Loopback5
 ip address 197.0.0.17 255.255.255.252
!

interface FastEthernet0/0
 description To MGMT
 ip address 198.18.0.103 255.255.255.0
 no ip split-horizon eigrp 10
#This command doesn't matter here (this interface doesn't participate in the EIGRP routing). It only demonstrates the possibility of disabling split horizon, which you may need on Frame Relay multipoint interface.
!
interface FastEthernet1/1
 description To R2
 no switchport
 bandwidth 90000
#When you specify bandwidth value on the interface, it affects other processes on the router (QoS calculation for example). Therefore adjustment of the Delay value is recommended for metric tuning in EIGRP. Besides, you need to configure the same bandwidth value on the other end of the link for correct metric calculations on all routers.
 ip address 10.0.0.10 255.255.255.252
 ip bandwidth-percent eigrp 10 30
#I specified 30% of the interface bandwidth for EIGRP traffic. In this case - 27 Mbps.
!
interface FastEthernet1/2
 description To R1
 no switchport
 ip address 10.0.0.6 255.255.255.252
 delay 9
!
interface FastEthernet1/4
 description To R4
 no switchport
 ip address 10.0.0.17 255.255.255.252
!
router eigrp 10
 variance 10
#All the FS routes with FD<(Successor_FD*Variance_Value) will be added to the routing table.
 passive-interface default
 no passive-interface FastEthernet1/1
 no passive-interface FastEthernet1/2
 no passive-interface FastEthernet1/4
 offset-list 10 in 100000 FastEthernet1/1
#To add some value to specific route metric you can specify the offset list and some value (100000) to add to RD and FD. It might be usable when you want to add FS routes to your Successor route.
 network 10.0.0.4 0.0.0.3
 network 10.0.0.8 0.0.0.3
 network 10.0.0.16 0.0.0.3
 network 172.16.0.0
#If you specify subnet of a classful network without WC, IOS will convert it to default classful network.
 network 197.0.0.0
 metric weights 0 0 0 1 0 0
 maximum-paths 6
#By default it equals 4. But for unequal-cost load balancing you may need to add more routes for specific prefix.
 distribute-list route-map Loopbacks197 out
#Instead of route map you can use prefix-list or an ACL. But route-map can combine both (see below).
 no auto-summary
 eigrp router-id 3.3.3.3
 neighbor 10.0.0.9 FastEthernet1/1
#If you use static neighbors on multiaccess media (Ethernet, Frame Relay), you have to specify all neighbors.
 neighbor 10.0.0.5 FastEthernet1/2
!
ip prefix-list net197.0.0.12/30 seq 5 permit 197.0.0.12/30 le 32
#See the route-map below.
access-list 10 permit 172.16.2.0 0.0.0.255
#Used with the offset list above.
access-list 11 permit 197.0.0.0 0.0.0.3
#See the route-map below.
!
route-map Loopbacks197 deny 10
 match ip address 11
#Notice that to match prefixes you have to specify "permit" command in the ACL.
!
route-map Loopbacks197 deny 20
 match ip address prefix-list net197.0.0.12/30
#The same for prefix-lists.
!
route-map Loopbacks197 permit 30
#As ACLs route-maps include at the end implicit "deny all". To override it, use permit clause with no match subcommand.
R4:
interface Loopback0
 ip address 172.16.4.1 255.255.255.0
!
interface FastEthernet1/3
 description To R1
 no switchport
 ip address 10.0.0.14 255.255.255.252
!
interface FastEthernet1/4
 description To R3
 no switchport
 ip address 10.0.0.18 255.255.255.252
!
router eigrp 10
 redistribute static
#You can use this command to announce a default route. But this router is stub router, which means that by default it won't advertise its static routes.
 passive-interface default
 no passive-interface FastEthernet1/3
 no passive-interface FastEthernet1/4
 network 10.0.0.12 0.0.0.3
 network 10.0.0.16 0.0.0.3
 network 172.16.4.0 0.0.0.255
 metric weights 0 0 0 1 0 0
 distribute-list prefix Interconnections in
 no auto-summary
 eigrp router-id 4.4.4.4
 eigrp stub static
#By default ("eigrp stub") IOS adds "connected" and "summary" keywords. In order to advertise default route you need to specify "static" keyword.
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
ip prefix-list Interconnections seq 5 deny 0.0.0.0/0 ge 30 le 30
#This clause will deny any prefixes with length that equals 30 (interconnect networks).
ip prefix-list Interconnections seq 10 permit 0.0.0.0/0 le 32
#Don't forget about implicit "deny all".
To verify these features here is the actual output from routers:
R1#sh ip route
Gateway of last resort is 10.0.0.2 to network 200.0.0.0
D*   200.0.0.0/24 [90/130560] via 10.0.0.2, 04:20:48, FastEthernet1/0
     20.0.0.0/22 is subnetted, 1 subnets
D       20.0.0.0 [90/2816] via 10.0.0.2, 04:20:48, FastEthernet1/0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.1.0 is directly connected, Loopback0
D       172.16.2.0 [90/130560] via 10.0.0.2, 04:20:48, FastEthernet1/0
D       172.16.3.0 [90/130304] via 10.0.0.6, 04:20:48, FastEthernet1/2
     197.0.0.0/30 is subnetted, 3 subnets
D       197.0.0.4 [90/130304] via 10.0.0.6, 04:20:48, FastEthernet1/2
D       197.0.0.8 [90/130304] via 10.0.0.6, 04:20:48, FastEthernet1/2
D       197.0.0.16 [90/130304] via 10.0.0.6, 04:20:48, FastEthernet1/2
C    198.18.0.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/30 is subnetted, 5 subnets
D       10.0.0.8 [90/4864] via 10.0.0.6, 04:20:48, FastEthernet1/2
C       10.0.0.12 is directly connected, FastEthernet1/3
C       10.0.0.0 is directly connected, FastEthernet1/0
C       10.0.0.4 is directly connected, FastEthernet1/2
D       10.0.0.16 [90/4864] via 10.0.0.6, 04:20:48, FastEthernet1/2
D*EX 0.0.0.0/0 [170/28160] via 10.0.0.14, 04:20:48, FastEthernet1/3
R2#sh ip route
Gateway of last resort is not set
C*   200.0.0.0/24 is directly connected, Loopback4
     20.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C       20.0.0.0/24 is directly connected, Loopback1
D       20.0.0.0/22 is a summary, 04:34:26, Null0
C       20.0.1.0/24 is directly connected, Loopback2
C       20.0.2.0/24 is directly connected, Loopback3
     172.16.0.0/24 is subnetted, 3 subnets
D       172.16.1.0 [90/130560] via 10.0.0.1, 04:21:33, FastEthernet1/0
C       172.16.2.0 is directly connected, Loopback0
D       172.16.3.0 [90/130560] via 10.0.0.10, 04:21:33, FastEthernet1/1
     197.0.0.0/30 is subnetted, 3 subnets
D       197.0.0.4 [90/130560] via 10.0.0.10, 04:21:33, FastEthernet1/1
D       197.0.0.8 [90/130560] via 10.0.0.10, 04:21:33, FastEthernet1/1
D       197.0.0.16 [90/130560] via 10.0.0.10, 04:21:33, FastEthernet1/1
C    198.18.0.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/30 is subnetted, 5 subnets
C       10.0.0.8 is directly connected, FastEthernet1/1
D       10.0.0.12 [90/5120] via 10.0.0.1, 04:21:33, FastEthernet1/0
C       10.0.0.0 is directly connected, FastEthernet1/0
D       10.0.0.4 [90/4864] via 10.0.0.10, 04:22:27, FastEthernet1/1
                 [90/4864] via 10.0.0.1, 04:22:27, FastEthernet1/0
D       10.0.0.16 [90/5120] via 10.0.0.10, 04:21:33, FastEthernet1/1
D*EX 0.0.0.0/0 [170/30720] via 10.0.0.10, 04:22:30, FastEthernet1/1
               [170/30720] via 10.0.0.1, 04:22:30, FastEthernet1/0
R3#sh ip route
Gateway of last resort is 10.0.0.9 to network 200.0.0.0
D*   200.0.0.0/24 [90/130560] via 10.0.0.9, 04:21:54, FastEthernet1/1
     20.0.0.0/22 is subnetted, 1 subnets
D       20.0.0.0 [90/2816] via 10.0.0.9, 04:21:54, FastEthernet1/1
     172.16.0.0/24 is subnetted, 3 subnets
D       172.16.1.0 [90/130304] via 10.0.0.5, 04:21:54, FastEthernet1/2
D       172.16.2.0 [90/230560] via 10.0.0.9, 04:21:54, FastEthernet1/1
                   [90/132864] via 10.0.0.5, 04:21:54, FastEthernet1/2
C       172.16.3.0 is directly connected, Loopback0
     197.0.0.0/30 is subnetted, 5 subnets
C       197.0.0.4 is directly connected, Loopback2
C       197.0.0.0 is directly connected, Loopback1
C       197.0.0.12 is directly connected, Loopback4
C       197.0.0.8 is directly connected, Loopback3
C       197.0.0.16 is directly connected, Loopback5
C    198.18.0.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/30 is subnetted, 5 subnets
C       10.0.0.8 is directly connected, FastEthernet1/1
D       10.0.0.12 [90/4864] via 10.0.0.5, 04:21:54, FastEthernet1/2
D       10.0.0.0 [90/5120] via 10.0.0.9, 04:21:54, FastEthernet1/1
                 [90/4864] via 10.0.0.5, 04:21:54, FastEthernet1/2
C       10.0.0.4 is directly connected, FastEthernet1/2
C       10.0.0.16 is directly connected, FastEthernet1/4
D*EX 0.0.0.0/0 [170/28160] via 10.0.0.18, 04:21:54, FastEthernet1/4
R4#sh ip route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
D*   200.0.0.0/24 [90/133120] via 10.0.0.17, 04:23:00, FastEthernet1/4
                  [90/133120] via 10.0.0.13, 04:23:00, FastEthernet1/3
     20.0.0.0/22 is subnetted, 1 subnets
D       20.0.0.0 [90/5376] via 10.0.0.17, 04:23:51, FastEthernet1/4
     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.4.0 is directly connected, Loopback0
D       172.16.1.0 [90/130560] via 10.0.0.13, 04:22:03, FastEthernet1/3
D       172.16.2.0 [90/133120] via 10.0.0.13, 04:22:03, FastEthernet1/3
D       172.16.3.0 [90/130560] via 10.0.0.17, 04:22:03, FastEthernet1/4
C    198.18.0.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/30 is subnetted, 2 subnets
C       10.0.0.12 is directly connected, FastEthernet1/3
C       10.0.0.16 is directly connected, FastEthernet1/4
S*   0.0.0.0/0 is directly connected, FastEthernet0/0

No comments:

Post a Comment