Logically it is a hub-and-spoke topology.
By default R2, R3 and R4 are able to ping only R1 and not each other, because frame relay routing is specified on FRSW.
FRSW - Frame Relay Switch configuration:
frame-relay switching
!
interface Serial0/0
description To R1
encapsulation frame-relay #Default encapsulation for frame relay is cisco.
clock rate 64000 #It is an DCE device (see the next command), therefore we need to specify the speed of the interface.
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201 #Specify source DLCI and destination interface and the destination DLCI.
frame-relay route 103 interface Serial0/2 301 #DLCI number has only local significance.
frame-relay route 104 interface Serial0/3 401 #Thus we set up hub-and-spoke topology.
!
interface Serial0/1
description To R2
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102 #Specify the path from each spoke router to the hub router.
!
interface Serial0/2
description To R3
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
!
interface Serial0/3
description To R4
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay intf-type dce
frame-relay route 401 interface Serial0/0 104
Basic Frame Relay configuration.
R1 configuration:
interface Serial0/0
ip address 10.0.0.1 255.255.255.0
encapsulation frame-relay
frame-relay lmi-type cisco #Actually, we don't need to specify LMI type because "cisco" is default.
On other routers we only change IP addresses according to the first picture.
At this point R1 has L3 connectivity with all other routers:
R1#ping 10.0.0.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/29/64 ms
We don't need to specify DLCI on R1, R2, R3, R4 because the LMI does all the work. And inverse ARP creates L2 to L3 mappings:
R1#sh frame-relay map
Serial0/0 (up): ip 10.0.0.2 dlci 102(0x66,0x1860), dynamic,
broadcast,, status defined, active
Serial0/0 (up): ip 10.0.0.3 dlci 103(0x67,0x1870), dynamic,
broadcast,, status defined, active
Serial0/0 (up): ip 10.0.0.4 dlci 104(0x68,0x1880), dynamic,
broadcast,, status defined, active
As stated above, R2, R3 and R4 can only ping R1:
R3#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/44/80 ms
But not each other:
R4#ping 10.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
To ping each other they need to be configured with inverse ARP mappings. Example for R2 and R3:
R2:
interface Serial0/1
ip address 10.0.0.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 10.0.0.3 201 broadcast
R2#ping 10.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3:
interface Serial0/2
ip address 10.0.0.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 10.0.0.2 301 broadcast
R3#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/44/72 ms
You also can configure different interfaces types:
- point to point: each spoke will be put in a different subnet;
- point to multipoint: all routers in the same subnet (Frame Relay is NBMA).
In any of these scenarios R1 will route all traffic.
Configuring point to point interfaces.
R1:
interface Serial0/0
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
!
interface Serial0/0.102 point-to-point
description To R2
ip address 10.0.0.1 255.255.255.252
frame-relay interface-dlci 102
!
interface Serial0/0.103 point-to-point
description To R3
ip address 10.0.0.5 255.255.255.252
frame-relay interface-dlci 103
!
interface Serial0/0.104 point-to-point
description To R4
ip address 10.0.0.9 255.255.255.252
frame-relay interface-dlci 104
Now we don't need LMI to get DLCI numbers. Instead we specify them with frame-relay interface-dlci command. Now we use point to point sub-interfaces, which means that it is no more NBMA and so shows inverse arp mappings:
R1#show frame-relay map
Serial0/0.104 (up): point-to-point dlci, dlci 104(0x68,0x1880), broadcast
status defined, active
Serial0/0.102 (up): point-to-point dlci, dlci 102(0x66,0x1860), broadcast
status defined, active
Serial0/0.103 (up): point-to-point dlci, dlci 103(0x67,0x1870), broadcast
status defined, active
We changed addressing scheme, so we have to do the same on spoke routers. R2 as example:
interface Serial0/1
ip address 10.0.0.2 255.255.255.252
Notice, that we don't need to configure sub-interfaces on spoke routers.
Now all routers can ping R1. To make them able to ping each other we need to specify default route (routers in different subnets now). R2 as example:
ip route 0.0.0.0 0.0.0.0 10.0.0.1
Notice, that if you specify here interface instead of IP-address, you will not be able to ping hosts in other subnets unless you create manual L2-L3 mapping (e.g. R3(config-if)#frame-relay map ip 10.0.0.10 301 broadcast).
Now routers should have full connectivity:
R3#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/52/96 ms
R3#ping 10.0.0.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/56/88 ms
The main reason why you should configure point to point sub-interfaces is to avoid the split-horizon issue with routing protocols.
Configuring point to multipoint interfaces.
R1:
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.10 multipoint
ip address 10.0.0.1 255.255.255.0
frame-relay map ip 10.0.0.2 102 broadcast
frame-relay map ip 10.0.0.3 103 broadcast
frame-relay map ip 10.0.0.4 104 broadcast
On other routers we only change IP-addresses. R2 as example:
interface Serial0/2
ip address 10.0.0.3 255.255.255.0
encapsulation frame-relay
Now all router can ping R1. To ping each other they need to be configured with inverse ARP mappings. Example for R2 and R3:
R2:
interface Serial0/1
ip address 10.0.0.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 10.0.0.3 201 broadcast
R2#ping 10.0.0.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3:
interface Serial0/2
ip address 10.0.0.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 10.0.0.2 301 broadcast
R3#ping 10.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/44/72 ms
No comments:
Post a Comment