Wednesday, December 12, 2012

BGP configuration.

This lab combines almost all CCNP related BGP features. The lab design is as following:
Below are configuration files from all of the routers with comments. Not relevant commands are omitted.

R1:
interface Loopback0 #This loopback is beign used as RID among the routing processess.
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback10
#These loopbacks below was created after BGP configuration. They are used for route summarization.
 ip address 192.168.0.1 255.255.255.252
!
interface Loopback11
 ip address 192.168.0.5 255.255.255.252
!
interface Loopback12
 ip address 192.168.0.9 255.255.255.252
!
interface Loopback13
 ip address 192.168.0.13 255.255.255.252
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 10.0.1.1 255.255.255.0
!
interface FastEthernet0/0.12
 encapsulation dot1Q 12
 ip address 10.0.12.1 255.255.255.0
!
interface FastEthernet0/0.13
 encapsulation dot1Q 13
 ip address 10.0.13.1 255.255.255.0
!
router eigrp 1
#iBGP neighbors use full-mesh topology due to BGP split-horizon-like behavior. iBGP peers also use the loopbacks as update-source, so they should be reachable (via IGP or static routes). BGP AS 100 uses EIGRP 1 as it's IGP.
 network 1.1.1.1 0.0.0.0
 network 10.0.1.0 0.0.0.255
 network 10.0.12.0 0.0.0.255
 network 10.0.13.0 0.0.0.255
 network 192.168.0.0 0.0.255.255
 no auto-summary
!
router bgp 100
 no synchronization
#This is the default command. If the synchromization is enabled, a prefix from the iBGP peer won't be considered as best unless this exact prefix was learned from IGP and installed in the routing table.
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 100
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary
#If the mask parameter of the network statement (related to some classful network) is omitted and auto-summary is enabled, router will add this classful network in the table if the exact prefix or any subnets exist in the routing table. If no auto-summary configured, BGP will install this prefix only if the exact prefix exists in the routing table.

R2:
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.0.2.1 255.255.255.0
!
interface FastEthernet0/0.12
 encapsulation dot1Q 12
 ip address 10.0.12.2 255.255.255.0
!
interface FastEthernet0/0.24
 encapsulation dot1Q 24
 ip address 10.0.24.2 255.255.255.0
!
router eigrp 1
 network 2.2.2.2 0.0.0.0
 network 10.0.2.0 0.0.0.255
 network 10.0.12.0 0.0.0.255
 network 10.0.24.0 0.0.0.255
 no auto-summary
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 4.4.4.4 remote-as 100
 neighbor 4.4.4.4 update-source Loopback0
 no auto-summary


R3:
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0.3
 encapsulation dot1Q 3
 ip address 10.0.3.1 255.255.255.0
!
interface FastEthernet0/0.13
 encapsulation dot1Q 13
 ip address 10.0.13.3 255.255.255.0
!
interface FastEthernet0/0.34
 encapsulation dot1Q 34
 ip address 10.0.34.3 255.255.255.0
!
interface FastEthernet0/0.35
 encapsulation dot1Q 35
 ip address 10.0.35.3 255.255.255.0
!
router eigrp 1
 network 3.3.3.3 0.0.0.0
 network 10.0.13.0 0.0.0.255
 network 10.0.34.0 0.0.0.255
 network 10.0.35.0 0.0.0.255
 no auto-summary
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.0.3.0 mask 255.255.255.0
 redistribute eigrp 1 route-map EIGRP2BGP
#There is two methods for advertising prefixes in the BGP - by network statement (which makes it's Origin code as "i") or by IGP redistribution (Origin code is "?"). When redistributing IGP, you can specify a route-map to filter prefixes or adjust their parameters. Route-map EIGRP2BGP allows only prefix 10.0.1.0/24 to be redistributed into BGP (refer to the route-map and prefix-list below).
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 4.4.4.4 remote-as 100
 neighbor 4.4.4.4 update-source Loopback0
 neighbor 10.0.35.5 remote-as 200
#BGP uses some additional security mechanism for eBGP neighbors - it sets TTL=1 which means that neighbor should be in the one hop away. To overcome this (e.g. you are establishing neighborship using loopback interfaces) you can use "ebg-multihop TTL" command.
 neighbor 10.0.35.5 password bgp_pass #BGP supports MD5 authentication, which requires the same password on both neighboring routers.
 neighbor 10.0.35.5 route-map LOCPREF10.0.5.0/24 in #Local preference is being used inside the AS (among the iBGP peers; Local preference is not being advertised to any eBGP peers) to select one and only one exit point for some particular prefix. In this example I am using route-map to set local preference for the exact one prefix 10.0.5.0/24 (refer to the route-map and prefix-list below). Notice, that after applying any route-map for a neighbor you need to reset this peer.
 no auto-summary
!
ip prefix-list net10.0.1.0/24 seq 5 permit 10.0.1.0/24
!
ip prefix-list net10.0.5.0/24 seq 5 permit 10.0.5.0/24
!
route-map EIGRP2BGP permit 10
#In this route-map there is only one permit statement which means that all other prefixes will be filtered due to implicit deny at the end of the route-map.
 match ip address prefix-list net10.0.1.0/24
!
route-map LOCPREF10.0.5.0/24 permit 10
 match ip address prefix-list net10.0.5.0/24
 set local-preference 1000
!
route-map LOCPREF10.0.5.0/24 permit 20
#And in this route-map I set the local-preference for one particular prefix and allowed all other prefixes without any changes.

R4:
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0.4
 encapsulation dot1Q 4
 ip address 10.0.4.1 255.255.255.0
!
interface FastEthernet0/0.24
 encapsulation dot1Q 24
 ip address 10.0.24.4 255.255.255.0
!
interface FastEthernet0/0.34
 encapsulation dot1Q 34
 ip address 10.0.34.4 255.255.255.0
!
interface FastEthernet0/0.46
 encapsulation dot1Q 46
 ip address 10.0.46.4 255.255.255.0
!
router eigrp 1
 network 4.4.4.4 0.0.0.0
 network 10.0.24.0 0.0.0.255
 network 10.0.34.0 0.0.0.255
 network 10.0.46.0 0.0.0.255
 no auto-summary
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 192.168.0.0 mask 255.255.255.252
#In order to advertise summary route you need at least one subnet in the BGP table.
 network 192.168.0.4 mask 255.255.255.252
 network 192.168.0.8 mask 255.255.255.252
 network 192.168.0.12 mask 255.255.255.252
 aggregate-address 192.168.0.0 255.255.255.240 summary-only
#Key-word "summary-only" suppresses advertisement of subnets for this summary route.
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 3.3.3.3 remote-as 100
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 10.0.46.6 remote-as 200
 neighbor 10.0.46.6 route-map DENY10.0.6.0/24 in
#You can filter particular prefixes from being advertised to neighbors using route-maps, prefix-lists, filter-lists (for AS access-lists) and distribute lists. Route-map is the most flexible tool among these. This one filters prefix 10.0.6.0/24 and allows all others.
 no auto-summary
!
ip prefix-list net10.0.6.0/24 seq 5 permit 10.0.6.0/24
!
route-map DENY10.0.6.0/24 deny 10
 match ip address prefix-list net10.0.6.0/24
!
route-map DENY10.0.6.0/24 permit 20


R5:
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0.5
 encapsulation dot1Q 5
 ip address 10.0.5.1 255.255.255.0
!
interface FastEthernet0/0.35
 encapsulation dot1Q 35
 ip address 10.0.35.5 255.255.255.0
!
interface FastEthernet0/0.56
 encapsulation dot1Q 56
 ip address 10.0.56.5 255.255.255.0
!
router ospf 1
#BGP AS 200 uses OSPF as its' IGP.
 log-adjacency-changes
 network 10.0.35.0 0.0.0.255 area 0
 network 10.0.56.0 0.0.0.255 area 0
!
router bgp 200
 no synchronization
 bgp router-id 5.5.5.55
#If no RID was specified, BGP (as other routing protocols) will use highest loopback IP and, if none configured, highest non-loopback interface in the up/up state.
 bgp log-neighbor-changes
 network 10.0.5.0 mask 255.255.255.0
 network 10.0.56.0 mask 255.255.255.0
 neighbor 10.0.35.3 remote-as 100
 neighbor 10.0.35.3 password bgp_pass
 neighbor 10.0.35.3 soft-reconfiguration inbound
#In case of requirement to see advertised routes from a prticular neighbor, you need to configure this feature. It actually consumes some additional memory to store all updates from neighbor before filtering (show ip bgp neighbor 10.0.35.3 received-routes).
 neighbor 10.0.35.3 route-map WEIGHT10.0.1.0/24 in #Weight is only locally significant an is not being advertised to any neighbors. But you can indirectly influence the path for particular prefix, because BGP advertises only its' best routes. This particular route-map sets weight of 10000 for one prefix - 10.0.1.0/24 (refer to the route-map and access-list below).
 neighbor 10.0.56.6 remote-as 200
 no auto-summary
!
access-list 1 permit 10.0.1.0 0.0.0.255
!
route-map WEIGHT10.0.1.0/24 permit 10
 match ip address 1
 set weight 10000
!
route-map WEIGHT10.0.1.0/24 permit 20


R6:
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface Loopback10
 ip address 10.0.10.1 255.255.255.0
!
interface FastEthernet0/0.6
 encapsulation dot1Q 6
 ip address 10.0.6.1 255.255.255.0
!
interface FastEthernet0/0.46
 encapsulation dot1Q 46
 ip address 10.0.46.6 255.255.255.0
!
interface FastEthernet0/0.56
 encapsulation dot1Q 56
 ip address 10.0.56.6 255.255.255.0
router ospf 1
 log-adjacency-changes
 network 10.0.56.0 0.0.0.255 area 0
#Notice that this OSPF process doesn't advertise network on the interconnection link between R4 and R6. In BGP terms this means that routes received from R4 will not be used by R5 via R6 because next-hop-ip (R4) will be unreachable. This is because iBGP peers by default don't change next-hop address of advertised prefixes. To overcome this you can use static routes or "next-hop-self statement" (refer to the BGP configuration below).
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 10.0.6.0 mask 255.255.255.0
 network 10.0.10.0 mask 255.255.255.0
 network 10.0.56.0 mask 255.255.255.0
 neighbor 10.0.46.4 remote-as 100
 neighbor 10.0.46.4 route-map ASPATH192.168.0.0/28 in
#Another way to influence the path selection is the AS-Path prepend mechanism (BGP will choose those routes with the shortest AS_Path attribute). This particular route-map prepends 5 autonomous systems (refer to the route-map and prefix-list below) to one particular prefix - 192.168.0.0/28 (aggregate route from R4).
 neighbor 10.0.46.4 route-map MED10.0.10.0/24 out #In order to influence path selection in the neighboring AS you can set MED value and advertise prefixes with this MED into neighboring AS. The mechanics behind the scene is somehow similar to EIGRP feasible successor selection - you set higher MED value for less preferable prefixes and vise versa. This route-map sets metric (MED) to 20000 for prefix 10.0.10.0/24 (refer to the route-map and prefix-list configuration below).
 neighbor 10.0.56.5 remote-as 200
 neighbor 10.0.56.5 next-hop-self
#As was mentioned in the OSPF section above you can advertise prefixes to iBGP peers changing default next-hop to itself to overcome the issue with the next-hop reachability.
 neighbor 10.0.56.5 route-map ORIGIN10.0.5.0/24 in #Another tool to influence inbound routes is setting the code of origin (e - EGP, i - Internal, ? - Incomplete). The preference is as follows: i -> e -> ?. This route-map sets code of origin to "e" for prefix 10.0.5.0/24.
 no auto-summary
!
ip prefix-list net10.0.10.0/24 seq 5 permit 10.0.10.0/24
!
ip prefix-list net10.0.5.0/24 seq 5 permit 10.0.5.0/24
!
ip prefix-list net192.168.0.0/28 seq 5 permit 192.168.0.0/16 ge 28 le 28
!
route-map ASPATH192.168.0.0/28 permit 10
 match ip address prefix-list net192.168.0.0/28
 set as-path prepend 1 2 3 4 5
!
route-map ASPATH192.168.0.0/28 permit 20
!
route-map ORIGIN10.0.5.0/24 permit 10
 match ip address prefix-list net10.0.5.0/24
 set origin egp 10
!
route-map ORIGIN10.0.5.0/24 permit 20
!
route-map MED10.0.10.0/24 permit 10
 match ip address prefix-list net10.0.10.0/24
 set metric 20000
!
route-map MED10.0.10.0/24 permit 20


To verify these features here is the actual output from the routers:
R1#show ip route
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 10.0.12.2, 02:06:17, FastEthernet0/0.12
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/409600] via 10.0.13.3, 02:09:14, FastEthernet0/0.13
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/435200] via 10.0.13.3, 00:03:49, FastEthernet0/0.13
                [90/435200] via 10.0.12.2, 00:03:49, FastEthernet0/0.12
C    198.18.0.0/24 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 13 subnets
B       10.0.10.0 [200/0] via 10.0.35.5, 00:04:58
C       10.0.12.0 is directly connected, FastEthernet0/0.12
C       10.0.13.0 is directly connected, FastEthernet0/0.13
D       10.0.2.0 [90/307200] via 10.0.12.2, 02:11:58, FastEthernet0/0.12
B       10.0.3.0 [200/0] via 3.3.3.3, 00:12:00
C       10.0.1.0 is directly connected, FastEthernet0/0.1
B       10.0.6.0 [200/0] via 10.0.35.5, 00:04:58
B       10.0.5.0 [200/0] via 10.0.35.5, 00:12:00
D       10.0.24.0 [90/307200] via 10.0.12.2, 02:11:02, FastEthernet0/0.12
D       10.0.46.0 [90/332800] via 10.0.13.3, 00:03:49, FastEthernet0/0.13
                  [90/332800] via 10.0.12.2, 00:03:49, FastEthernet0/0.12
D       10.0.34.0 [90/307200] via 10.0.13.3, 00:03:49, FastEthernet0/0.13
D       10.0.35.0 [90/307200] via 10.0.13.3, 01:50:50, FastEthernet0/0.13
B       10.0.56.0 [200/0] via 10.0.35.5, 00:12:00
     192.168.0.0/24 is variably subnetted, 5 subnets, 2 masks
C       192.168.0.8/30 is directly connected, Loopback12
C       192.168.0.12/30 is directly connected, Loopback13
C       192.168.0.0/30 is directly connected, Loopback10
B       192.168.0.0/28 [200/0] via 4.4.4.4, 00:13:17
C       192.168.0.4/30 is directly connected, Loopback11
R2#show ip route
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/409600] via 10.0.12.1, 00:03:40, FastEthernet0/0.12
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/435200] via 10.0.24.4, 00:03:42, FastEthernet0/0.24
                [90/435200] via 10.0.12.1, 00:03:42, FastEthernet0/0.12
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/409600] via 10.0.24.4, 00:03:42, FastEthernet0/0.24
C    198.18.0.0/24 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 13 subnets
B       10.0.10.0 [200/0] via 10.0.35.5, 00:04:52
C       10.0.12.0 is directly connected, FastEthernet0/0.12
D       10.0.13.0 [90/307200] via 10.0.12.1, 00:03:43, FastEthernet0/0.12
C       10.0.2.0 is directly connected, FastEthernet0/0.2
B       10.0.3.0 [200/0] via 3.3.3.3, 00:11:54
D       10.0.1.0 [90/307200] via 10.0.12.1, 00:03:40, FastEthernet0/0.12
B       10.0.6.0 [200/0] via 10.0.35.5, 00:04:52
B       10.0.5.0 [200/0] via 10.0.35.5, 00:11:54
C       10.0.24.0 is directly connected, FastEthernet0/0.24
D       10.0.46.0 [90/307200] via 10.0.24.4, 00:03:42, FastEthernet0/0.24
D       10.0.34.0 [90/307200] via 10.0.24.4, 00:03:43, FastEthernet0/0.24
D       10.0.35.0 [90/332800] via 10.0.24.4, 00:03:43, FastEthernet0/0.24
                  [90/332800] via 10.0.12.1, 00:03:43, FastEthernet0/0.12
B       10.0.56.0 [200/0] via 10.0.46.6, 00:03:06
     192.168.0.0/24 is variably subnetted, 5 subnets, 2 masks
D       192.168.0.8/30 [90/409600] via 10.0.12.1, 00:03:40, FastEthernet0/0.12
D       192.168.0.12/30
           [90/409600] via 10.0.12.1, 00:03:40, FastEthernet0/0.12
D       192.168.0.0/30 [90/409600] via 10.0.12.1, 00:03:40, FastEthernet0/0.12
B       192.168.0.0/28 [200/0] via 4.4.4.4, 00:13:11
D       192.168.0.4/30 [90/409600] via 10.0.12.1, 00:03:40, FastEthernet0/0.12
R3#show ip route
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/409600] via 10.0.13.1, 02:06:51, FastEthernet0/0.13
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/435200] via 10.0.34.4, 00:03:33, FastEthernet0/0.34
                [90/435200] via 10.0.13.1, 00:03:33, FastEthernet0/0.13
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     4.0.0.0/32 is subnetted, 1 subnets
D       4.4.4.4 [90/409600] via 10.0.34.4, 02:08:13, FastEthernet0/0.34
C    198.18.0.0/24 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 13 subnets
B       10.0.10.0 [20/0] via 10.0.35.5, 00:04:43
D       10.0.12.0 [90/307200] via 10.0.13.1, 00:03:33, FastEthernet0/0.13
C       10.0.13.0 is directly connected, FastEthernet0/0.13
D       10.0.2.0 [90/332800] via 10.0.34.4, 00:03:33, FastEthernet0/0.34
                 [90/332800] via 10.0.13.1, 00:03:33, FastEthernet0/0.13
C       10.0.3.0 is directly connected, FastEthernet0/0.3
D       10.0.1.0 [90/307200] via 10.0.13.1, 02:10:46, FastEthernet0/0.13
B       10.0.6.0 [20/0] via 10.0.35.5, 00:04:43
B       10.0.5.0 [20/0] via 10.0.35.5, 00:11:45
D       10.0.24.0 [90/307200] via 10.0.34.4, 02:10:46, FastEthernet0/0.34
D       10.0.46.0 [90/307200] via 10.0.34.4, 01:50:23, FastEthernet0/0.34
C       10.0.34.0 is directly connected, FastEthernet0/0.34
C       10.0.35.0 is directly connected, FastEthernet0/0.35
B       10.0.56.0 [20/0] via 10.0.35.5, 00:11:45
     192.168.0.0/24 is variably subnetted, 5 subnets, 2 masks
D       192.168.0.8/30 [90/409600] via 10.0.13.1, 01:38:12, FastEthernet0/0.13
D       192.168.0.12/30
           [90/409600] via 10.0.13.1, 01:38:12, FastEthernet0/0.13
D       192.168.0.0/30 [90/409600] via 10.0.13.1, 01:38:12, FastEthernet0/0.13
B       192.168.0.0/28 [200/0] via 4.4.4.4, 00:11:45
D       192.168.0.4/30 [90/409600] via 10.0.13.1, 01:38:12, FastEthernet0/0.13
R4#show ip route
     1.0.0.0/32 is subnetted, 1 subnets
D       1.1.1.1 [90/435200] via 10.0.34.3, 00:03:24, FastEthernet0/0.34
                [90/435200] via 10.0.24.2, 00:03:24, FastEthernet0/0.24
     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 10.0.24.2, 00:03:24, FastEthernet0/0.24
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/409600] via 10.0.34.3, 02:08:50, FastEthernet0/0.34
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
C    198.18.0.0/24 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 14 subnets
B       10.0.10.0 [200/0] via 10.0.35.5, 00:04:34
D       10.0.12.0 [90/307200] via 10.0.24.2, 00:03:24, FastEthernet0/0.24
D       10.0.13.0 [90/307200] via 10.0.34.3, 00:03:24, FastEthernet0/0.34
D       10.0.2.0 [90/307200] via 10.0.24.2, 00:03:24, FastEthernet0/0.24
B       10.0.3.0 [200/0] via 3.3.3.3, 00:11:36
D       10.0.1.0 [90/332800] via 10.0.34.3, 00:03:24, FastEthernet0/0.34
                 [90/332800] via 10.0.24.2, 00:03:24, FastEthernet0/0.24
B       10.0.6.0 [200/0] via 10.0.35.5, 00:04:34
C       10.0.4.0 is directly connected, FastEthernet0/0.4
B       10.0.5.0 [200/0] via 10.0.35.5, 00:11:36
C       10.0.24.0 is directly connected, FastEthernet0/0.24
C       10.0.46.0 is directly connected, FastEthernet0/0.46
C       10.0.34.0 is directly connected, FastEthernet0/0.34
D       10.0.35.0 [90/307200] via 10.0.34.3, 01:50:26, FastEthernet0/0.34
B       10.0.56.0 [20/0] via 10.0.46.6, 00:05:18
     192.168.0.0/24 is variably subnetted, 5 subnets, 2 masks
D       192.168.0.8/30 [90/435200] via 10.0.34.3, 00:03:24, FastEthernet0/0.34
                       [90/435200] via 10.0.24.2, 00:03:24, FastEthernet0/0.24
D       192.168.0.12/30
           [90/435200] via 10.0.34.3, 00:03:24, FastEthernet0/0.34
           [90/435200] via 10.0.24.2, 00:03:24, FastEthernet0/0.24
D       192.168.0.0/30 [90/435200] via 10.0.34.3, 00:03:24, FastEthernet0/0.34
                       [90/435200] via 10.0.24.2, 00:03:24, FastEthernet0/0.24
B       192.168.0.0/28 [200/0] via 0.0.0.0, 00:12:53, Null0
D       192.168.0.4/30 [90/435200] via 10.0.34.3, 00:03:25, FastEthernet0/0.34
                       [90/435200] via 10.0.24.2, 00:03:25, FastEthernet0/0.24
R5#show ip route
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
C    198.18.0.0/24 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 7 subnets
B       10.0.10.0 [200/0] via 10.0.56.6, 00:04:24
B       10.0.3.0 [20/0] via 10.0.35.3, 00:11:26
B       10.0.1.0 [20/307200] via 10.0.35.3, 00:11:26
B       10.0.6.0 [200/0] via 10.0.56.6, 00:04:24
C       10.0.5.0 is directly connected, FastEthernet0/0.5
C       10.0.35.0 is directly connected, FastEthernet0/0.35
C       10.0.56.0 is directly connected, FastEthernet0/0.56
     192.168.0.0/28 is subnetted, 1 subnets
B       192.168.0.0 [20/0] via 10.0.35.3, 00:11:26
R6#show ip route
     6.0.0.0/32 is subnetted, 1 subnets
C       6.6.6.6 is directly connected, Loopback0
C    198.18.0.0/24 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 8 subnets
C       10.0.10.0 is directly connected, Loopback10
B       10.0.3.0 [20/0] via 10.0.46.4, 00:04:57
B       10.0.1.0 [20/0] via 10.0.46.4, 00:04:57
C       10.0.6.0 is directly connected, FastEthernet0/0.6
B       10.0.5.0 [200/0] via 10.0.56.5, 00:04:57
C       10.0.46.0 is directly connected, FastEthernet0/0.46
O       10.0.35.0 [110/20] via 10.0.56.5, 01:32:27, FastEthernet0/0.56
C       10.0.56.0 is directly connected, FastEthernet0/0.56
     192.168.0.0/28 is subnetted, 1 subnets
B       192.168.0.0 [200/0] via 10.0.35.3, 00:04:57


R1#show ip bgp
BGP table version is 75, local router ID is 1.1.1.1
   Network          Next Hop            Metric LocPrf Weight Path
*>i10.0.3.0/24      3.3.3.3                  0    100      0 i
*>i10.0.5.0/24      10.0.35.5                0   1000      0 200 i
*>i10.0.6.0/24      10.0.35.5                0    100      0 200 i
*>i10.0.10.0/24     10.0.35.5                0    100      0 200 i
* i10.0.56.0/24     10.0.46.6                0    100      0 200 i
*>i                 10.0.35.5                0    100      0 200 i
*>i192.168.0.0/28   4.4.4.4                  0    100      0 i
R2#show ip bgp
BGP table version is 88, local router ID is 2.2.2.2
   Network          Next Hop            Metric LocPrf Weight Path
r>i10.0.1.0/24      10.0.13.1           307200    100      0 ?
*>i10.0.3.0/24      3.3.3.3                  0    100      0 i
*>i10.0.5.0/24      10.0.35.5                0   1000      0 200 i
*>i10.0.6.0/24      10.0.35.5                0    100      0 200 i
*>i10.0.10.0/24     10.0.35.5                0    100      0 200 i
*>i10.0.56.0/24     10.0.46.6                0    100      0 200 i
* i                 10.0.35.5                0    100      0 200 i
*>i192.168.0.0/28   4.4.4.4                  0    100      0 i
R3#show ip bgp
BGP table version is 12, local router ID is 3.3.3.3
   Network          Next Hop            Metric LocPrf Weight Path
*> 10.0.1.0/24      10.0.13.1           307200         32768 ?
*> 10.0.3.0/24      0.0.0.0                  0         32768 i
*> 10.0.5.0/24      10.0.35.5                0   1000      0 200 i
*> 10.0.6.0/24      10.0.35.5                              0 200 i
*> 10.0.10.0/24     10.0.35.5                              0 200 i
* i10.0.56.0/24     10.0.46.6                0    100      0 200 i
*>                  10.0.35.5                0             0 200 i
*>i192.168.0.0/28   4.4.4.4                  0    100      0 i
R4#show ip bgp
BGP table version is 52, local router ID is 4.4.4.4
   Network          Next Hop            Metric LocPrf Weight Path
r>i10.0.1.0/24      10.0.13.1           307200    100      0 ?
*>i10.0.3.0/24      3.3.3.3                  0    100      0 i
*  10.0.5.0/24      10.0.46.6                              0 200 e
*>i                 10.0.35.5                0   1000      0 200 i
*>i10.0.6.0/24      10.0.35.5                0    100      0 200 i
*>i10.0.10.0/24     10.0.35.5                0    100      0 200 i
*                   10.0.46.6            20000             0 200 i
*> 10.0.56.0/24     10.0.46.6                0             0 200 i
* i                 10.0.35.5                0    100      0 200 i
s> 192.168.0.0/30   10.0.24.2           435200         32768 i
*> 192.168.0.0/28   0.0.0.0                            32768 i
s> 192.168.0.4/30   10.0.24.2           435200         32768 i
s> 192.168.0.8/30   10.0.24.2           435200         32768 i
s> 192.168.0.12/30  10.0.24.2           435200         32768 i
R5#show ip bgp
BGP table version is 47, local router ID is 5.5.5.55
   Network          Next Hop            Metric LocPrf Weight Path
* i10.0.1.0/24      10.0.56.6                0    100      0 100 ?
*>                  10.0.35.3           307200         10000 100 ?
* i10.0.3.0/24      10.0.56.6                0    100      0 100 i
*>                  10.0.35.3                0             0 100 i
*> 10.0.5.0/24      0.0.0.0                  0         32768 i
*>i10.0.6.0/24      10.0.56.6                0    100      0 i
*>i10.0.10.0/24     10.0.56.6                0    100      0 i
* i10.0.56.0/24     10.0.56.6                0    100      0 i
*>                  0.0.0.0                  0         32768 i
*> 192.168.0.0/28   10.0.35.3                              0 100 i
R6#show ip bgp
BGP table version is 10, local router ID is 10.0.10.1
   Network          Next Hop            Metric LocPrf Weight Path
* i10.0.1.0/24      10.0.35.3           307200    100      0 100 ?
*>                  10.0.46.4                              0 100 ?
* i10.0.3.0/24      10.0.35.3                0    100      0 100 i
*>                  10.0.46.4                              0 100 i
*>i10.0.5.0/24      10.0.56.5                0    100      0 e
*> 10.0.6.0/24      0.0.0.0                  0         32768 i
*> 10.0.10.0/24     0.0.0.0                  0         32768 i
*> 10.0.56.0/24     0.0.0.0                  0         32768 i
* i                 10.0.56.5                0    100      0 i
*>i192.168.0.0/28   10.0.35.3                0    100      0 100 i
*                   10.0.46.4                0             0 1 2 3 4 5 100 i


R1#show ip bgp summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 75, main routing table version 75
6 network entries using 720 bytes of memory
7 path entries using 364 bytes of memory
5/4 BGP path/bestpath attribute entries using 620 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1728 total bytes of memory
BGP activity 13/7 prefixes, 55/48 paths, scan interval 60 secs
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4   100     129     129       75    0    0 02:05:30        0
3.3.3.3         4   100     186     140       75    0    0 00:12:32        5
4.4.4.4         4   100     173     137       75    0    0 00:13:37        2
R2#show ip bgp summary
BGP router identifier 2.2.2.2, local AS number 100
BGP table version is 88, main routing table version 88
7 network entries using 840 bytes of memory
8 path entries using 416 bytes of memory
6/5 BGP path/bestpath attribute entries using 744 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2024 total bytes of memory
BGP activity 14/7 prefixes, 59/51 paths, scan interval 60 secs
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4   100     129     129       88    0    0 02:05:23        0
3.3.3.3         4   100     184     139       88    0    0 00:12:25        6
4.4.4.4         4   100     172     136       88    0    0 00:13:30        2
R3#show ip bgp summary
BGP router identifier 3.3.3.3, local AS number 100
BGP table version is 12, main routing table version 12
7 network entries using 840 bytes of memory
8 path entries using 416 bytes of memory
8/6 BGP path/bestpath attribute entries using 992 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 3 (at peak 4) using 96 bytes of memory
BGP using 2368 total bytes of memory
BGP activity 35/28 prefixes, 67/59 paths, scan interval 60 secs
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4   100     139     186       12    0    0 00:12:17        0
2.2.2.2         4   100     138     184       12    0    0 00:12:17        0
4.4.4.4         4   100     189     202       12    0    0 00:12:15        2
10.0.35.5       4   200     214     205       12    0    0 00:12:16        4
R4#show ip bgp summary
BGP router identifier 4.4.4.4, local AS number 100
BGP table version is 52, main routing table version 52
11 network entries using 1320 bytes of memory
14 path entries using 728 bytes of memory
10/7 BGP path/bestpath attribute entries using 1240 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 3 (at peak 4) using 96 bytes of memory
BGP using 3408 total bytes of memory
BGP activity 43/32 prefixes, 85/71 paths, scan interval 60 secs
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4   100     137     173       52    0    0 00:13:12        0
2.2.2.2         4   100     136     172       52    0    0 00:13:13        0
3.3.3.3         4   100     202     190       52    0    0 00:12:06        6
10.0.46.6       4   200     205     232       52    0    0 00:05:23        3
R5#show ip bgp summary
BGP router identifier 5.5.5.55, local AS number 200
BGP table version is 47, main routing table version 47
7 network entries using 840 bytes of memory
11 path entries using 572 bytes of memory
8/5 BGP path/bestpath attribute entries using 992 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 3 (at peak 4) using 96 bytes of memory
BGP using 2524 total bytes of memory
1 received paths for inbound soft reconfiguration
BGP activity 34/27 prefixes, 98/87 paths, scan interval 60 secs
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.35.3       4   100     204     215       47    0    0 00:11:56        3
10.0.56.6       4   200     250     250       47    0    0 00:05:12        5
R6#show ip bgp summary
BGP router identifier 10.0.10.1, local AS number 200
BGP table version is 10, main routing table version 10
7 network entries using 840 bytes of memory
11 path entries using 572 bytes of memory
11/5 BGP path/bestpath attribute entries using 1364 bytes of memory
2 BGP AS-PATH entries using 64 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 3 (at peak 3) using 96 bytes of memory
BGP using 2936 total bytes of memory
BGP activity 51/44 prefixes, 113/102 paths, scan interval 60 secs
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.46.4       4   100     232     206       10    0    0 00:05:04        3
10.0.56.5       4   200     250     252       10    0    0 00:05:04        5

No comments:

Post a Comment